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Installation and Startup

Before installing, verify that you have cc:Mail, Microsoft Mail or Microsoft
Exchange already installed and working on your computer. Virtual Courier
requires that you can successfully send mail to and receive mail from your
mail system. 

Each user who plans to use Virtual Courier on this computer to exchange
mail with their mailbox must be able to login to the mail system (cc:Mail,
Microsoft Mail or Microsoft Exchange) from this computer.

For Windows 95:

1. Start Windows 95.
2. Insert the Virtual Courier installation disk into your floppy drive.
3. Click the Start button and select Run... from the menu.
4. Type a:setup into the Open: box and select the OK button.
5. Follow the instructions on the screen. You will be prompted for a sub

directory to place the Virtual Courier program files.

For Windows NT:

1. Start Windows
2. Insert the Virtual Courier installation disk into your floppy drive.
3. Select Run from the File menu of Program Manager.
4. Type a:setup into the Command Line box and select the OK button.
5. Follow the instructions on the screen. You will be prompted for a 

subdirectory to place Virtual Courier program files.

Depending on whether you choose to install for cc:Mail or Microsoft
Mail/Exchange, a program group named Virtual Courier for ccMail or
Virtual Courier for MS Mail/Exchange will be created on your desktop.
To start Virtual Courier, double-click on the icon labeled Virtual Courier.

INSTALLATION
▼

If you are running Windows 95, please follow the steps outlined below:

Step 1. Install Virtual Courier. See Page 5. 
Step 2. Configure Virtual Courier. See Page 6.
Step 3. If you want to use a modem to remotely access the Virtual Courier,

install and configure the Dial-up Server. See Page 8. Alternatively,
if you want to use the direct cable see Appendix I.

Step 4. Configure the Remote Networking and Inbox on your HPC. See
Page 12.

If you are running Windows NT 3.51 or higher, please follow the steps
outlined below:

Step 1. Install Virtual courier. See Page 5. 
Step 2. Configure Virtual Courier. See Page 6. 
Step 3. If you want to use a modem to remotely access the Virtual Courier,

install and configure the Remote Access Service. See Page 14,
alternatively, if you want to use the direct cable connection see
Appendix II.

Step 4. Configure the Remote Networking and Inbox on your HPC. See
Page 20.
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Quick Configuration of Virtual Courier

The Configuration Settings dialog allows you to configure settings for
Startup, User Registration, Mail Options, and Logging options. The configu-
ration settings are accessed by choosing Configuration Settings... from the
Setup menu.

Following the steps below to quickly configure the Virtual Courier.
1) Press OK when prompted for password
2) Select “Security” tab from the “Configuration Settings” dialog
3) Press “Add User” 
4) Enter a name to identify yourself
5) Enter the user name and password for your specifc mail system
6) Depending on whether you are using cc:Mail or Microsoft Exchange,

you may be required to enter either the postoffice path or the an
exchange profile name

7) Confirm each dialog by clicking OK
8) If you want to change the information you just entered, choose “Edit

User” button from the “Configuration Settings” dialog

PC and HPC Configuration and Setup
The communication between HPC and PC is done via Remote Networking.
For Windows 95, this requires either Dial-up Server which is included in the
Microsoft Plus Pack or Direct Cable Connection . For Windows NT 3.51 or
later, the Remote Access Services must be installed and configured properly.

Configuring Dial-up Server in Windows 95

Access Control
After you have installed a modem and the Microsoft Plus Pack, select the
Network applet in the Control Panel. Choose Access Control and set the
Control-access to Share-level access control, as shown below.

3.1.2 TCP/IP Configuration
Click the Configuration tab and choose the TCP/IP entry. If you have more
than one entries, repeat the following steps.

Click Properties button. A dialog appears allowing the user to edit the TCP/IP
properties. 

Make sure the “Obtain an IP address automatically” is checked.

Click OK to accept the TCP/IP settings.

Confirm each dialog by clicking OK and re-start Windows 95.

Dial-Up Server
Launch Dial-Up Server application from My Computer folder. From the
Connections menu, select Dial-Up Server.

Select Allow caller access. Choose Change Password to specify a password for
remote connections.

Initially the old password is empty. In the New password field, type in the
password that the remote HPC will use to log in. For example, Washington.

Select Server Type. Make sure the type of dial-up server is PPP: Windows 95,
Windows NT 3.5, Internet. Don’t change the ‘Advanced options’.

In the Dial-Up Server dialog, click Apply to set the options you have just
specified. Now your Windows 95 PC is ready to automatically connect to
incoming calls.



Close the Remote Networking window and now run the Inbox application
(typically found on the desktop of your HPC device.. Choose “Options...” from
the Compose menu. Select the Services tap and tap Add.

From the Services list, select “Internet Mail”. Tap OK.

Enter a Service Name. Tap OK.

Select the remote connection. In the mail host entry field, enter the IP address
for your PC.* In our example, the mail host is 192.168.55.101. Put in the
User ID and password to log on to your mail system. Check the “Remember
password” checkbox. Tap “Finished”.

* NOTE: First you can try the ‘default’ IP address given above, however to
confirm that you have entered the correct Mail Host IP addresss, establish a
connection between your HPC and desktop and then if running a Windows
95 PC, run WINIPCFG to verify the IP address. In Windows NT use 
IPCONFIG.

Configuring Your HPC device
To connect your HPC to a PC running Windows 95 with Microsoft Plus Pack
installed, you need to configure both the Remote Networking and Inbox
application on your HPC.

1) Run Remote Networking 
(Location: My Handheld PC/Progams/Communications). 

2) Double tap “Make a new connection”.

3) Type a name for the connection and select Dial-Up Connection..Click Next.

4) Choose the correct modem type. Enter your correct phone number for the
remote modem you are calling. Click “TCP/IP Settings...”.

IMPORTANT: Check Server-assigned IP address so that it is not selected. In
the IP address field, enter 192.168.55.100.

Choose OK and positively confirm the remaining dialog boxes.



Now you are ready to send and receive messages from the Virtual Courier.
From the Service menu, select Connect.

The HPC will dial the PC and establish the remote connection. Inbox appli-
cation will then try to locate the mail host (SMTP and POP3 servers). The
Virtual Courier must be running on the remote PC to initiate the mail trans-
actions. If everything works fine, the status window of the Virtual Courier
will indicate that there are connections. 

The Inbox will start to download message headers for any new messages.
After it is done, you will see something similar to the following figure.

To read the message, double tap on the new message.

Windows NT

Installing/configuring Remote Access Service (RAS)
The remote connection between the handheld and the PC require RAS to be
installed on Windows NT. Please follow the instructions below for configur-
ing RAS.

1) Go to “Start -> Settings -> Control Panel”
2) Double-click on “Network”
3) Select the “Services” tab
4) If “Remote Access Service” is not listed:

A) Click “Add”
B) In the listbox, select “Remote Access Service”
C) Click “OK”
D) The “Windows NT Setup” dialog will appear, asking where 

the location of the NT files. Change the location to the drive 
and directory where your NT disks/CD-ROM are located.

E) Your NT disks/CD-ROM will be required here, as RAS will 
now be installed

5) In the “Network Services” listbox, select “Remote Access Service” 
and click “Properties”

6) If the COM port you wish to use is displayed in the listbox, you will 
need to remove it. Select the COM port, click “Remove”, and then 
“Yes” to confirm

7) In the “Remote Access Setup” dialog, click “Add”
8) Click “Install Modem” and “Next”. This may take a while, since NT

will try to detect the modem attached to your communication ports
9) If NT cannot find the specific type of modem you are using, or the 

information given is not what you want, you can manually change 
it. In the “Manufacturers” list select the modem type of your modem, 
and in the “Models” list, select the specific modem, and click “Next”

10) Select the “Selected ports” radio button, and select the COM port you 
will use (e.g. COM1, COM2) to connect to the modem, and click Next.

11) Take note of any warning or informational messages that may pop 
up



20) Select the “This computer only” radio button
21) Select the “Use static address pool” radio button, and for “Begin”, 

enter “192.168.55.100”. For “End”, enter “192.168.55.105”
22) Make sure the “Allow remote clients to request a predetermined IP 

address” is cleared
23) Continue by affirmatively exiting all the dialog boxes, and click 

“Close” when you reach the “Network” dialog.
24) If a “Microsoft TCP/IP Properties” dialog pops up, click “OK”
25) Restart your computer when asked

By default, RAS will automatically disconnect after 20 minutes.
To disable the auto-disconnect feature:

1) Start -> Run -> regedit
2) Window -> HKEY_LOCAL_MACHINE
3) Select the key 

“System\CurrentControlSet\Services\RemoteAccess\Parameters”
4) Select the value “Autodisconnect”
5) Edit -> DWORD
6) 0 in the “Data” field
7) OK

3.2.2 Setting permissions for a guest account
1) In “Programs” -> “Administrative Tools”, start “User Manager”
2) In the top box, double click on “Guest”

3) Make sure that the “Account Disabled” checkbox is FALSE
4) Click “OK” and close the “User Manager” dialog
5) In “Programs” -> “Administrative Tools”, start “Remote Access 

Admin”
6) Select “Users” -> “Permissions”
7) In the “Users” listbox, select “Guest”, and set the “Grant dialin per

mission to user” checkbox to TRUE
8) Click “OK”
9) Select “Server” -> “Start Remote Access Server”

12) If a “Location information” dialog pops up, type any 3-digit number 
in the “area code” (e.g. 408), and click “Next”

13) Continue by clicking “Finish”, and then affirmatively exiting all the
dialog boxes, until you reach the “Add RAS Device” dialog
14) The dropdown list should now contain the port that we have just 

configured. Select the port, and click “OK”. On some builds of NT,
the dropdown list may not display the port that was just added. If 
it does not, repeat steps 8-14. Eventually, NT will detect the modem.

15) In the “Remote Access Setup” dialog, select the port that we have just 
configured, and click “Configure”

16) Select “Receive calls only” radio button, and click “OK”
17) In the “Remote Access Setup” dialog, click “Network”
18) In the “Server Settings” group, set the “TCP/IP” checkbox to TRUE. 

If you have no other modem previously installed, then make sure the 
other checkboxes are cleared. Otherwise, leave the other checkbox
es as they were

19) Click the “Configure” button for “TCP/IP”



Sending an email message through Virtual Courier

For cc.mail

If using cc.mail -

Here is an example of the cc:Mail address form. For 
example: or 
Not just the name: JOE SMITH. 
Important: don't forget the <> around the address. 

Reminder: Virtual Courier is the Mail gateway for cc:Mail not 
Internet. So if you are sending to an internet user, you still must use 
cc:Mail's address form: "mannkeg" , NOT margim@juno.com. 

For MS Mail or Exchange

Configuring HPC for Windows NT

Configuring HPC for Windows NT is basically the same as for Windows 95.
One important difference is in the TCP/IP settings for the Remote Connection.
Make sure the “Server-assigned IP address” is checked.

Also the Mail Host should be the first address specified in the RAS Server
TCP/IP Settings dialog.. In our example, the mail host is 192.168.55.100.



Downloading email addresses 

(Virtual Courier Enhanced only)

Appendix I
Configuring Direct Cable Connection in Windows 95

The Direct Cable Connection application will be installed automatically when
you install Microsoft’s HPC Explorer. Before configuring the Direct Cable
Connection, shut down HPC Explorer.

- Launch Direct Cable Connection (it is called “Directcc.exe”)
- Select Host. 
- Follow the instructions on the screen

NOTE-- You may be required to share a directory in order to proceed. You
can share any directories. If you want to protect your system, you can choose
Use password protection and set a password for the remote HPC user. If you
leave it unchecked, any user can log onto your desktop.

After you are done, click Finish. Now the Direct Cable Connection is listen-
ing to the communication port for the incoming traffic.



12) Select “Receive calls only” radio button, and click “OK”
13) In the “Remote Access Setup” dialog, click “Network”
14) In the “Server Settings” group, set the “TCP/IP” checkbox to TRUE. 

If you have no other modem previously installed, then make sure the 
other checkboxes are cleared. Otherwise, leave the other checkbox
es as they were

15) Click the “Configure” button for “TCP/IP”
16) Select the “This computer only” radio button
17) Select the “Use static address pool” radio button, and for “Begin”, 

enter “192.168.55.100” for “End”, enter “192.168.55.105”
18) Make sure the “Allow remote clients to request a predetermined IP 

address” is cleared
19) Continue by affirmatively exiting all the dialog boxes, and click 

“Close” when you reach the “Network” dialog.
20) If a “Microsoft TCP/IP Properties” dialog pops up, click “OK”
21) Restart your computer when asked

By default, RAS will automatically disconnect after 20 minutes.
To disable the auto-disconnect feature:
1) Start -> Run -> regedit
2) Window -> HKEY_LOCAL_MACHINE
3) Select the key 

“System\CurrentControlSet\Services\RemoteAccess\Parameters”
4) Select the value “Autodisconnect”
5) Edit -> DWORD
6) 0 in the “Data” field
7) OK

(B) Setting permissions for a guest account
1) In “Programs” -> “Administrative Tools”, start “User Manager”
2) In the top box, double click on “Guest”
3) Make sure that the “Account Disabled” checkbox is FALSE
4) Click “OK” and close the “User Manager” dialog
5) In “Programs” -> “Administrative Tools”, start “Remote Access 

Admin”
6) Select “Users” -> “Permissions”
7) In the “Users” listbox, select “Guest”, and set the “Grant dialin per

mission to user” checkbox to TRUE
8) Click “OK”
9) Select “Server” -> “Select Domain or Server...”
10) In the “Domain” entry field, type in your machine name (e.g. MYA

CCOUNT1)
11) Click “OK”

Appendix II

Configuring Direct Cable Connection in Windows NT 4.0
The remote connection for Address Book Download between the desktop and
HPC require RAS to be installed on NT 4.0. Please follow the instructions
below for configuring RAS.
(A) Installing/configuring Remote Access Service (RAS)

1) Go to “Start -> Settings -> Control Panel”
2) Double-click on “Network”
3) Select the “Services” tab
4) If “Remote Access Service” is not listed:

A) Click “Add”
B) In the listbox, select “Remote Access Service”
C) Click “OK”
D) The “Windows NT Setup” dialog will appear, asking where 
the location of the NT files. Change the location to the drive and 
directory where your NT disks/CD-ROM are located.
E) Your NT disks/CD-ROM will be required here, as RAS will 
now be installed

1) In the “Network Services” listbox, select “Remote Access Service” 
and click “Properties”

2) If the COM port you wish to use is displayed in the listbox, you will 
need to remove it. Select the COM port, click “Remove”, and then 
“Yes” to confirm.

3) In the “Remote Access Setup” dialog, click “Add”
4) Click “Install Modem”, and set the “don’t detect my modem; I will 

select it from a list” checkbox to TRUE, and click “Next”. This may 
take a while, since a list of all supported modems is loaded

5) In the “Manufacturers” list select “Standard modem types” and in the 
“Models” list, select “Dial-Up Networking Serial Cable between 2 
PCs”, and click “Next”

6) Select the “Selected ports” radio button, and select the COM port you 
will use (e.g. COM1 or COM2) to connect to the device, and click 
“Next”

7) Take note of any warning or informational messages that may pop 
up

8) If a “Location information” dialog pops up, type any 3-digit number 
in the “area code” (e.g. 206), and click “Next”

9) Continue by clicking “Finish”, and then affirmatively exiting all the 
dialog boxes, until you reach the “Add RAS Device” dialog

10) The dropdown list should now contain the port that we have just 
configured. Select the port, and click “OK”. On some builds of NT,
the dropdown list may not display the port that was just added. If 
it does not, repeat steps 8-14. Eventually, NT will detect the modem.

11) In the “Remote Access Setup” dialog, select the port that we have just 
configured, and click “Configure”



Appendix IV - Common Questions

How can I send attachments like a MW Pocket Word or Excel file?

LandWare's EncloseIt will allow you to do just that. Complete details 
can be found on the EncloseIt web page.

Can I dial into my network through a server, but have Virtual Courier 
running back on my desktop PC?

Yes, but you will need to be sure to specify the IP address of your 
desktop computer in the In Box Properties dialog. Tip-- to check to make
sure you have access to your desktop from the server try to PING the IP 
address of your desktop. Also if you are running a DNS server, then each 
desktop on the network should have a name and thus you can use the name 
of your desktop instead of the IP address in the Mail Host field (if 
using this technique, make sure your Remote Networking TCP/IP settings 
have the correct Primary/Secondary DNS settings.) 

If I am running Virtual Courier on a server should I be worried that it 
will get in the way of anything?

No, it runs in the background. You could as an option run Virtual 
Courier on a separate node and configure your Windows CE-based device to 
access it using one of the options presented above. 

How does Virtual Courier know about the Exchange server? And how does 
Virtual Courier know if you are running MS-Mail for PC Networks or 
MS-Exchange?

Virtual Courier uses MAPI and CMC to detect whether it's dealing with 
Exchange or MS-Mail. The difference is that Exchange requires a profile 
to log on while MS-Mail requires user and password. 
Generally Virtual Courier should be installed on a machine with Exchange 
client (not Exchange server). 

I have Windows 95, will that run Virtual Courier?

The software will run, but to dial into your Windows 95 computer you 
will need the Plus! package from Microsoft. Plus! installs the dial-up 
server code needed to remotely access your desktop. 

Will Virtual Courier let me access my Lotus Notes email?

Not currently.

I have Windows NT, do I need anything else to run Virtual Courier?

Appendix III - Trouble Shooting 

I get a "VIM.DLL is missing" message, what should I do?

Step 1:
Reinstall Virtual Courier and make sure the step where the installer asks you
to identify where you have cc.mail installed is completed. 

If even after a reinstall I get the same message, then what?

Step 2:
1. Use Find... to find where the VIM.DLL is.
2. Run RegEdit.Exe (User Start/Run...)
3. Find popsrvcc
4. Edit the Path entry to include the path where VIM.DLL is.

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersoin\App Paths\popsrvcc\

Path Value should be similar to the following: 
C:\Progra~1\Virtu~1;C:\CCMAIL\BIN; 

I get an SMTP error #9 when I connect. What should I do?

Confirm that you have entered the correct IP address of your Mail Host into
the HPC. To review your setting select in the InBox application: Service->
Properties...-> Mail host:. 

How can I check the IP address of the desktop computer I am using with 
Virtual Courier?

In Windows 95, run WINIPCFG to verify the IP address. In Windows NT use 
IPCONFIG.



Finally
LandWare and Microburst welcome your feedback— so if there are new fea-
tures that you would like us to consider, applications we should develop or
general comments please feel free to contact us at the address detailed below.

Copyright and Distribution Notice
Please remember that Virtual Courier is a commercial product and are pro-
tected by strict copyright laws. Any unauthorized distribution is illegal.

Contact Information
LandWare, Inc.
PO Box 25
Oradell, NJ 07649
USA
Telephone (201) 261-7944
Fax (201) 261-7949
AOL landware
CompuServe 102404,3627
Internet info@landware.com
Web http://www.landware.com

No, Windows NT has everything you need to run and remotely access 
Virtual Courier.

I have Windows 3.x, will this run Virtual Courier?

No. 

What modems will Virtual Courier work with?

Virtual Courier will work with all WIndows CE compatible modems. 

Is a 28.8 modem required?

No. Note-- until someone releases a 'low-power' 28.8 modem they will 
decrease your battery life much more then a 14.4. 

With the Enhanced version can I support multiple users at the same time 
by having a Windows NT computer with multiple modems attached?

Yes. 

What platform is recommended if we want to use multiple users?

We strongly recommend a Windows NT 4.0 (or later) computer for 
multi-user support. 

Is it true that I don't have to install any software on my Windows 
CE-based device?

Yes, you only need to set up a new email service in the InBox and Remote 
Access setup on the Windows CE-based device and install the Virtual 
Courier software on your desktop computer.

How big is the Virtual Courier application?

The .exe file is 305K and there are misc. support files for the 
application that add up to less then 50K. Once running Virtual Courier 
can be minimized and will run in the background. 

Can the Lite version of Virtual Courier download my addresses?

No, you need to upgrade to the enhanced version (which also 
provides access for up to 20 usrs.) 




